WordPressでBackWPupがエラーになるときに確認するべきこと

随分前からWordPressのバックアップにBackWPupというプラグインを使っています。ひとことでいうと自動でバックアップとってくれるというものですが、サーバの中はもちろん、Dropboxにバックアップすることもできるというスグレモノです。

そんなBackWPupですが、私の場合毎週エラーがメールで届いていました。なんとなく気持ちが悪いと思いつつ、クリティカルではないと勝手に踏んで(でも多分致命的です)あまり真剣に考えていませんでした。

ところがさすがに長く放置しすぎたと思ったので、まじめに解決しようと調べてみたところ、どうやらPHPのバージョンに問題があるとのこと。

詳しく解説してくれているサイトもありました。

via: B型おとめ座の男 WordPressバックアップ|BackWPupをロリポップで使う方法
via: BackWPup ver. 3も大丈夫。ロリポップでは、MySQLiはPHP 5.4で使えるのだった。 | WordPressとサーバでいきましょ

PHPのバージョンで5.4にしないと「MySQLi」というMySQLの拡張を使えないことでエラーが発生していたようです。

早速ロリポップサーバのPHPバージョンをあげてみたところ問題のエラーが解消されました。すばらしい。ただ、自分の場合は容量の問題で別のエラーがでてはいますが、本質的なところは前進したのですっきりしました。

情報を公開してくれてたみなさん。ありがとうございました。 
 

コメントを残す